Platforms & Browsers Supported

Estimated reading time: < 1 min

Browsers

kulcare works flawlessly on all the modern browsers on any computer. See a full list of compatible browsers below:

    • Microsoft Edge (version 79 and above)
    • Google Chrome (version 79 and above)
    • Mozilla Firefox (version 73 and above)
    • Apple Safari (version 13 and above)

Other browsers based on Webkit, Blink & Gecko engines should run kulcare smoothly.

If you face any issues, please let us know.


Apps

Android app

kulcare for Doctors, compatible with up to date android versions (Android 8,9,10) is available on the play store ↗

iOS App

kulcare for Doctors, compatible with up to three latest iOS versions (iOS 11,12,13) is available on the app store  

Compatibility with versions not mentioned above may be limited & is not actively tested.
Was this article helpful?
No 0 of 0 found this article helpful.
Views: 28
Previous: Features of kulcare
Next: Help & Support